Problém s oživováním

Problém s oživováním

Příspěvekod Khejml » 05.01.2015 10:16

Zdravím, mám problém rozchodit motory.
Tiskárnu mám komplet postavenou a zapojenou. Problém nastal už když jsem ji zapojil přes USB (hlavní napájení nezapojeno). Virtuální COM se v zařízení objevil a hned zase zmizel. Zkusil jsem připojit jen Arduino s RAMPs (neupravovaný) - to zafungovalo a tak jsem do Arduina nahrál FW (Repetier_RII_91_V8_full_GLCD_JRC). Pak jsem postupně připojil termistory, koncáky a až jsem začal zapojovat drivery, tak se po zapojení USB začala elektronika chovat divně (port se v PC odpojil a LCD začalo poblikávat). Začal jsem tedy postupně vždy jen jeden driver osazovat. Z 5 driverů 2 znefunkčnily Arduino, 1 fungoval s poblikáváním LCD, 2 fungovaly bezvadně. Osadil jsem tedy pouze dva do X a Y.
Spustil jsem Repetier a dle návodu otestoval koncáky a teplotu na termistorech - vše OK. Pak jsem připojil zdroj, po chvíli jsem chtěl akorát zkusit pohnout X motorem o 10 mm a než jsem stačil kliknout na příslušné tlačítko, začalo se z driveru Y kouřit. Po vypnutí a vyndání zničeného driveru jsem testoval jen s X, který sice drží, ale po zaslání příkazu o posunutí nedělá s motorem nic (ani po zvýšení napětí na cca 0,7V). Motor je studený, nevydává žádný zvuk.
Nějaké nápady? Pro jistotu jsem objednal nový RAMPs a drivery DRV8825.
  • 0

REBEL II v.30
Arduino Mega 2560 + RAMPS1.4 + DRV 8825 + full graf.LCD + SD card reader
Khejml
 
Příspěvky: 19
Registrován: 27.02.2014 12:30
Bydliště: Most
Reputation: 0

Re: Problém s oživováním

Příspěvekod Rebel » 05.01.2015 10:32

vypada to na vadny driver. sice jsem to stesti u DRV8825 jeste nemel, ale muze se stat. Bohuzel jsem naopak zazil diky jednomu spatnemu driveru (respektive spatne zapojenemu, bud presazenim o pin, nebo otocenim), zniceni ostatnich driveru a vypaleni arduina.
Na RAMPS jako takovem se nemam moc co skazit, tim to nebude.
Idealni je vzit jen jeden driver a postupne ho posazovat do patic a vzdy odzkouset jen jednu osu.
Az vse chny odzkousis, tak potom teprve nastrkat zbyle drivery, nebo je pro jistotu odzkouset jednotlive drivery stejnym zpusobem na jedne z os.
Zkus co ti zbylo a z ceho se nezakourilo, tedy vzdy jen jeden driver a dej vedet.
  • 0

Dan - Rebel ? ;) - http://rebelove.org - Rebel I-III, Rebel sCUBE, Anycubic i3 MEGA, Anycubic - Kossel Mini ! A naučte se používat pro STL přílohy čudlík "UMÍSTIT DO PŘÍSPĚVKU" !
Rebel
 
Příspěvky: 3017
Images: 243
Registrován: 12.08.2013 11:44
Bydliště: HK
Reputation: 15

Re: Problém s oživováním

Příspěvekod oscar » 05.01.2015 11:20

ja bych si spis vsadil na otoceni driveru. nikdo neni neomylny a ve spechu se leccos prehledne. navic 1/16 a 1/32 drivery jsou vizualne obracene proti pinoutu
  • 0

.... večer se přezujou, hodinu frézujou ....
oscar
 
Příspěvky: 698
Images: 4
Registrován: 16.06.2014 20:51
Bydliště: Perníkovice
Reputation: 6

Re: Problém s oživováním

Příspěvekod Khejml » 05.01.2015 14:07

oscar píše:ja bych si spis vsadil na otoceni driveru. nikdo neni neomylny a ve spechu se leccos prehledne. navic 1/16 a 1/32 drivery jsou vizualne obracene proti pinoutu


Ahoj, nerozumím tomuto - 1/16 a 1/32 drivery jsou vizualne obracene proti pinoutu, můžeš to rozvést? díky
  • 0

REBEL II v.30
Arduino Mega 2560 + RAMPS1.4 + DRV 8825 + full graf.LCD + SD card reader
Khejml
 
Příspěvky: 19
Registrován: 27.02.2014 12:30
Bydliště: Most
Reputation: 0

Re: Problém s oživováním

Příspěvekod Rebel » 05.01.2015 14:16

Mysleno asi tak, ze pohledove nejdou zamenit 1:1, protoze maji umisteni trimru na druhe strane cipu. Takze kdyz je menis a posadis je do soklu pohledove stejne, tak odprasis pri nejmensim jen ten driver.
DRV8825.jpg
a4988.jpg
  • 0

Nemáte oprávnění prohlížet přiložené soubory.
Dan - Rebel ? ;) - http://rebelove.org - Rebel I-III, Rebel sCUBE, Anycubic i3 MEGA, Anycubic - Kossel Mini ! A naučte se používat pro STL přílohy čudlík "UMÍSTIT DO PŘÍSPĚVKU" !
Rebel
 
Příspěvky: 3017
Images: 243
Registrován: 12.08.2013 11:44
Bydliště: HK
Reputation: 15

Re: Problém s oživováním

Příspěvekod Khejml » 05.01.2015 14:27

Drivery co mám jsou A4988, zbyl mi jeden a jak jsem psal na příkaz z Repetieru nereaguje. Zkusím ještě proměřit motory a zkusit je cuknout na 9V baterku. Na posunutí driverů jsem si dával pozor i na jejich natočení - řídil jsem se popiskem na plošňáku.
  • 0

REBEL II v.30
Arduino Mega 2560 + RAMPS1.4 + DRV 8825 + full graf.LCD + SD card reader
Khejml
 
Příspěvky: 19
Registrován: 27.02.2014 12:30
Bydliště: Most
Reputation: 0

Re: Problém s oživováním

Příspěvekod oscar » 05.01.2015 14:31

jednoduse:
zmer jestli je napeti na GND-VMOT 12V
zmer jestli se po hybnuti motorkem zmeni napeti na pinu ENABLE
pokud jsou one odpovedi kladne, a motor neztuhnul, zkontroluj zapojeni 1A,1B,2A,2B
  • 0

.... večer se přezujou, hodinu frézujou ....
oscar
 
Příspěvky: 698
Images: 4
Registrován: 16.06.2014 20:51
Bydliště: Perníkovice
Reputation: 6

Re: Problém s oživováním

Příspěvekod Car » 05.01.2015 14:38

rozpoj Arduino a Ramps - zapoj jen Arduino k PC a budeli ti svítit zelená je Arduino vpořádku - odpoj napájení .
Zapoj zpět Ramps do Arduina a opět propoj s PC - jestli se ti rozsvítí nic nebo červená máš problém .
Pokud nic nejspíš jsi přišel o diodu vedle těch vratných pojistek
Pokud bude svítit zelená je to O.K. a problém je jen v driverech
Tak nějak nepředpokládám ,že jsi zkoušel Drivery pouštět bez nalepených chladičů , ale už i to se tu stalo ,tak pro jistotu na drivery patří AL chladiče a když to budeš ještě ofukovat větrákem nic se nestane.
  • 0

Konstrukce Prusa i2 ,Rebel 2 ,PEEK hotend 3mm i 1,75mm vlastní výroba ,Marlin , Ramps 1.4 ,motory Microcon SX17 -0905 ,KISSlicer64
Car
 
Příspěvky: 646
Registrován: 28.04.2014 23:13
Bydliště: Olomouc
Reputation: 0

Re: Problém s oživováním

Příspěvekod Rebel » 05.01.2015 15:04

Bohuzel tak jednoznacne to skutecne neni. Pokud sviti zelena, je to sice fajn, ale neznamena to, ze nejsou vypalene I/O EN, DIR, nebo STEP a nebo nakopnuta atmega na arduinu.
Bohuzel ze vseho co je tu popsano mam pocit, ze jedine co bude ok, tak je RAMPS.
  • 0

Dan - Rebel ? ;) - http://rebelove.org - Rebel I-III, Rebel sCUBE, Anycubic i3 MEGA, Anycubic - Kossel Mini ! A naučte se používat pro STL přílohy čudlík "UMÍSTIT DO PŘÍSPĚVKU" !
Rebel
 
Příspěvky: 3017
Images: 243
Registrován: 12.08.2013 11:44
Bydliště: HK
Reputation: 15

Re: Problém s oživováním

Příspěvekod Khejml » 06.01.2015 08:45

Tak jsem to otestoval dle zdejších rad:
- po připojení holého Arduina se rozsvítí červená LED ON
- proměřil jsem cívky motoru jak jsou nyní zapojené v konektoru. Vždy každý pár má 5,7Ohm (1A,1B a 2A,2B)
- motor po krátkém připojení baterky na daný pár vinutí cuknul
- motory SX17-1005 mám zapojené takto 1B-modrá, 1A-bílá, 2A-černá, 2B-oranžová (propojeno červená-hnědá, žlutá-zelená)
- chtěl jsem změřit napětí na driveru, ale po zapnutí zdroje do sítě, se po cca 10s driver začne silně zahřívat. Po jeho vyndání v patici naměřeno VMOT-GND 12,2V

dál už jsem to nechtěl trápit...
  • 0

REBEL II v.30
Arduino Mega 2560 + RAMPS1.4 + DRV 8825 + full graf.LCD + SD card reader
Khejml
 
Příspěvky: 19
Registrován: 27.02.2014 12:30
Bydliště: Most
Reputation: 0

Re: Problém s oživováním

Příspěvekod Rebel » 06.01.2015 09:01

V jakem stavu je arduino, to se takto rici bohuzel neda. Pokud jde prehrat a komunikuje s Repetierem i bez RAMPS, nemusi to znamenat, ze ta Atmega je v cajku. Vetsinou se nakopnuty procesor vice hreje.

Spatnym pripojenim motoru se driver neznici.

Pokud se ten driver hreje a pritom motor neni blokovan, je na 100% v haji treba spatnym/opacnym nasazenim do RAMPS.

Napeti VMOT 12V je v poradku, to je primo napeti zdroje.
  • 0

Dan - Rebel ? ;) - http://rebelove.org - Rebel I-III, Rebel sCUBE, Anycubic i3 MEGA, Anycubic - Kossel Mini ! A naučte se používat pro STL přílohy čudlík "UMÍSTIT DO PŘÍSPĚVKU" !
Rebel
 
Příspěvky: 3017
Images: 243
Registrován: 12.08.2013 11:44
Bydliště: HK
Reputation: 15

Re: Problém s oživováním

Příspěvekod Car » 06.01.2015 11:34

Jestli mu svítí na Arduinu červená dioda hned po zapnutí ,tak má v háji něco na Arduinu . to to nemusí ani zkoušet dál . třeba ta ATmega může být přismažená ze vnitř.
  • 0

Konstrukce Prusa i2 ,Rebel 2 ,PEEK hotend 3mm i 1,75mm vlastní výroba ,Marlin , Ramps 1.4 ,motory Microcon SX17 -0905 ,KISSlicer64
Car
 
Příspěvky: 646
Registrován: 28.04.2014 23:13
Bydliště: Olomouc
Reputation: 0

Re: Problém s oživováním

Příspěvekod oscar » 06.01.2015 12:23

ja bych zacal definici ledek - ktera je ta cervena?
Obrázek

L, Rx,Tx nebo PWR?

edit:

koukam ze na nekterych subtypech se to fakt jmenuje ON
http://obchod.rebelove.org/elektronika/96497.html/96498.jpg

IMHO je ale uplne normalni a spravne ze ta ledka sviti. ve schematu je pres odpor mezi +5V a GND
  • 0

.... večer se přezujou, hodinu frézujou ....
oscar
 
Příspěvky: 698
Images: 4
Registrován: 16.06.2014 20:51
Bydliště: Perníkovice
Reputation: 6

Re: Problém s oživováním

Příspěvekod Rebel » 06.01.2015 12:30

LED PWR (nebo ON), sviti vzdy po pripojeni USB, pokud tedy je USB funkcni a nevyhorel tistak ci predrazeny odpor LED, coz je dost nepravdepodobne. Tudiz jeji rozsviceni znamena, ce je CPU pod napetim, tot vse.
  • 0

Dan - Rebel ? ;) - http://rebelove.org - Rebel I-III, Rebel sCUBE, Anycubic i3 MEGA, Anycubic - Kossel Mini ! A naučte se používat pro STL přílohy čudlík "UMÍSTIT DO PŘÍSPĚVKU" !
Rebel
 
Příspěvky: 3017
Images: 243
Registrován: 12.08.2013 11:44
Bydliště: HK
Reputation: 15

Re: Problém s oživováním

Příspěvekod Khejml » 06.01.2015 12:31

Svítí červeně po zapnutí PWR (já ji mám označenou jako ON)
  • 0

REBEL II v.30
Arduino Mega 2560 + RAMPS1.4 + DRV 8825 + full graf.LCD + SD card reader
Khejml
 
Příspěvky: 19
Registrován: 27.02.2014 12:30
Bydliště: Most
Reputation: 0

Další

Zpět na REBEL II

Kdo je online

Uživatelé procházející toto fórum: Yahoo [Bot] a 1 návštěvník